Degraded Payment Entry Performance
Incident Report for AdvancedMD
Resolved
This incident has been resolved.
Posted Oct 14, 2024 - 15:00 MDT
Monitoring
Our third-party partner, ProPay, experienced an issue with processing transactions. This issue has been resolved on their end, and we are receiving reports that payments are successfully processing. Our incident managers will continue to monitor the situation.
Posted Oct 14, 2024 - 14:04 MDT
Investigating
We are currently investigating an issue affecting several payment entry screens. Some users have reported freezing screens and errors. Our technical teams are actively working to resolve the issue. Incident Managers will continue to provide updates here as more information becomes available.
Posted Oct 14, 2024 - 13:40 MDT
This incident affected: Practice Management (PM).