Limited Access to Client Support Phone Lines

Incident Report for AdvancedMD

Resolved

This incident has been resolved.
Posted Feb 02, 2026 - 10:19 MST

Investigating

We are currently experiencing a network issue affecting our phone system. As a result, you may have difficulty reaching our Client Support team by phone. We are actively working to restore service.

Clients needing assistance are encouraged to use the Chat service in the meantime. Our Incident Managers will continue to post updates as new information becomes available.
Posted Feb 02, 2026 - 10:15 MST
This incident affected: Client Services Support.