Errors processing Credit Card Payments through AMDPay

Incident Report for AdvancedMD

Resolved

This incident has been resolved.
Posted Mar 12, 2026 - 13:30 MDT

Investigating

AdvancedMD clients using AMDPay are reporting errors when processing credit card payments. Our Incident Management team is engaged and will continue to provide updates here as additional information becomes available.
Posted Mar 12, 2026 - 13:11 MDT
This incident affected: Practice Management (PM).