Claim Inspector Processing Delays
Incident Report for AdvancedMD
Resolved
This incident has been resolved.
Posted Apr 18, 2024 - 09:10 MDT
Monitoring
A fix has been implemented and we are monitoring the results.
Posted Apr 18, 2024 - 08:56 MDT
Investigating
The Claim Inspector module is currently experiencing delays processing claims. Our technical teams are engaged and actively working to resolve the issue. Our incident managers will continue to provide updates here as additional information becomes available.
Posted Apr 18, 2024 - 07:52 MDT
This incident affected: Claim Inspector.