AdvancedMD Pay: Error Processing Credit Cards through Telehealth and Patient Portal
Incident Report for AdvancedMD
Resolved
This incident has been resolved.
Posted May 02, 2024 - 11:50 MDT
Monitoring
A fix has been implemented and we are monitoring the results.
Posted May 02, 2024 - 10:37 MDT
Identified
The issue has been identified, and a fix is being implemented. Users processing credit cards through AdvancedMD Pay in Telehealth and Patient Portal are impacted.
Posted May 02, 2024 - 09:18 MDT
Investigating
We are investigating an issue with processing Credit Cards through our Telehealth application. Our technical teams are actively working to resolve this situation. Our Incident Managers will provide updates as additional information becomes available.
Posted May 02, 2024 - 08:46 MDT
This incident affected: Patient Engagement (Patient Portal) and Telehealth (Telehealth).