Slowness in PM and EHR - Pool 133

Incident Report for AdvancedMD

Resolved

This incident has been resolved.
Posted Mar 10, 2026 - 14:20 MDT

Update

We are continuing to monitor for any further issues.
Posted Mar 10, 2026 - 12:27 MDT

Monitoring

A fix has been implemented and we are monitoring the results.
Posted Mar 10, 2026 - 12:26 MDT

Update

We are continuing to investigate this issue.
Posted Mar 10, 2026 - 12:03 MDT

Update

We are continuing to investigate this issue.
Posted Mar 10, 2026 - 11:01 MDT

Investigating

Some customers may notice slower than usual performance when using the Practice Management (PM) and Electronic Health Record (EHR) system.
Our teams are actively investigating and working to improve performance as quickly as possible. This issue is not affecting all customers and is currently limited to those within Pool 133.
We understand that performance issues can be disruptive, and we appreciate your patience. We will continue to share updates here as more information becomes available.
Posted Mar 10, 2026 - 10:18 MDT
This incident affected: Practice Management (PM) and Electronic Health Records (EHR).