Fax Disruption of Service

Incident Report for AdvancedMD

Resolved

This incident has been resolved.
Posted Mar 10, 2026 - 07:46 MDT

Investigating

Our third party partner, Updox, is currently experiencing a service disruption. Users may encounter errors when uploading, viewing, or sending documents. Our incident managers will continue to monitor the situation and provide updates as they become available. Users can subscribe to incident updates on Updox’s status page at https://partnerstatus.updox.com/.
Posted Mar 10, 2026 - 06:40 MDT
This incident affected: Fax.