A fix has been implemented and we are monitoring the results.
Posted Apr 14, 2025 - 13:46 MDT
Identified
The intermittent login errors have mostly subsided. Our technical teams remain engaged and are actively monitoring the situation. If users experience login errors, we recommend logging out and logging back in a couple of times.
Posted Apr 14, 2025 - 11:08 MDT
Update
We are continuing to investigate the intermittent login issue. Some clients have found success by reattempting to log in. We understand how disruptive this issue is for our clients. Our Incident Managers will continue to provide updates here as additional information becomes available.
Posted Apr 14, 2025 - 10:10 MDT
Investigating
We are investigating an issue where some users cannot successfully log in to the platform. Our technical teams are engaged and actively working to resolve the issue. Our Incident Managers will continue to provide updates here as additional information becomes available.
Posted Apr 14, 2025 - 09:22 MDT
This incident affected: Practice Management (PM) and Electronic Health Records (EHR).