A fix has been implemented and we are monitoring the results.
Posted Apr 03, 2026 - 15:13 MDT
Identified
The issue has been identified and a fix is being implemented.
Posted Apr 03, 2026 - 13:47 MDT
Update
We are continuing to investigate this issue.
Posted Apr 03, 2026 - 12:50 MDT
Investigating
We are currently investigating an issue affecting eligibility verification for some clients. Some users may be experiencing eligibility errors or delays in processing.
Our team has identified the issue and is actively working on a resolution. As a precautionary measure, we have implemented interim steps to restore processing, and queues are returning to normal levels.
We will provide a further update as soon as more information is available. We apologize for any inconvenience this may cause.
Posted Apr 03, 2026 - 11:31 MDT
This incident affected: Practice Management (PM) - Change Healthcare Integrations (Eligibility).