Optum (Change Healthcare) Claims Processing Delays

Incident Report for AdvancedMD

Resolved

All delayed claims have been processed. This incident is now resolved.
Posted Jun 12, 2026 - 09:08 MDT

Monitoring

Optum (Change Healthcare) has implemented a change and we are beginning to see claims transmit successfully. We will leave this incident open while we monitor to ensure all queued claims have processed. Please note that this may take many hours to fully complete. Our next update will be provided no later than tomorrow morning at 9:00 AM MT.
Posted Jun 11, 2026 - 17:01 MDT

Update

Optum (Change Healthcare) is actively working to resolve the claims processing delays. We will continue to provide updates as information becomes available.
Posted Jun 11, 2026 - 15:09 MDT

Identified

We have identified an issue with Optum (Change Healthcare) resulting in claims processing delays beginning June 10, 2026. All other Optum (Change Healthcare) integrations are functioning normally. No action is required — claims do not need to be rebilled and will process automatically once resolved.

We are actively engaged with Optum (Change Healthcare) and will provide updates as information becomes available.
Posted Jun 11, 2026 - 12:56 MDT
This incident affected: Practice Management (PM) - Optum (Change Healthcare) Integrations (Claim Submission).